Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 7504

Summary: gnome-terminal loses title when restoring session
Product: [Retired] Red Hat Linux Reporter: Tim Waugh <twaugh>
Component: gnome-coreAssignee: Havoc Pennington <hp>
Status: CLOSED RAWHIDE QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-17 17:49:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tim Waugh 1999-12-02 13:10:50 UTC
If you start gnome-terminal in gnome, and then log out saving settings,
when you log in again the window title is blank (and shows up as '???' in
the panel).

Comment 1 Havoc Pennington 1999-12-03 19:58:59 UTC
gnome-terminal code looks correct to me; this is likely a session manager
or gnome-libs problem. Needs a fairly in-depth investigation.

Comment 2 Preston Brown 2000-02-16 15:36:59 UTC
any progress here?

Comment 3 Havoc Pennington 2000-02-17 17:49:59 UTC
It works for me in Rawhide if you set the title with the --title command line
argument;
if you set the title with terminal escape sequences it deliberately doesn't
remember the title, since this is typically used to report current directory.