Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 7468

Summary: gnome-terminal does not set echok mode
Product: [Retired] Red Hat Linux Reporter: Chris Siebenmann <cks-rhbugzilla>
Component: gnome-coreAssignee: Havoc Pennington <hp>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-01-10 23:34:09 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Chris Siebenmann 1999-12-01 08:53:53 UTC
Gnome-terminal fails to set echok mode in its stty settings
(check with 'stty -a'). In a shell or other environment that
doesn't do its own command-line editing, this means that
typing some control characters looks (but does not act like)
they had no effect, such as your line-kill character.

Environment: gnome-terminal being started from inside an
xterm (with echok set).

Comment 1 Havoc Pennington 2000-01-10 23:34:59 UTC
Upstream maintainer (Michael Zucchi (zucchi@zedzone.mmc.com.au)) claims that
this setting is a matter of opinion and he doesn't think it should be set.