Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 7439

Summary: New kernel detects the version wrong when upgrading.
Product: [Retired] Red Hat Raw Hide Reporter: Pekka Savola <pekkas>
Component: kernelAssignee: Michael K. Johnson <johnsonm>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-06 05:57:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Pekka Savola 1999-11-30 10:36:08 UTC
I'm using a Redhat 6.0 kernel (2.2.5-22), and when I try to upgrade
to the newest 2.2.13-0.4 from Rawhide, I get the following conflicts:
----
error: failed dependencies:
	kernel <= 2.2 conflicts with initscripts-4.16-1
	kernel < 2.2.0 conflicts with nscd-2.1.1-6
	kernel < 2.2 conflicts with raidtools-0.90-3
	kernel <= 2.2 conflicts with initscripts-4.16-1
	kernel < 2.2.0 conflicts with nscd-2.1.1-6
	kernel < 2.2 conflicts with raidtools-0.90-3
	kernel <= 2.2 conflicts with initscripts-4.16-1
	kernel < 2.2.0 conflicts with nscd-2.1.1-6
	kernel < 2.2 conflicts with raidtools-0.90-3
----

This is obviously wrong, since the kernel being upgraded is 2.2.5, not
2.0*.

I didn't test if e.g. stock RH6.1 kernel has the same problems.

Comment 1 Bill Nottingham 1999-11-30 16:17:59 UTC
Make sure you grab the latest rpm RPM.

Comment 2 Pekka Savola 1999-11-30 17:38:59 UTC
I think not - see bug #7446.

Comment 3 maavl 1999-12-01 15:08:59 UTC
I think the problem might not be the absence of a sufficiently new kernel, but
the presence of an old one; after all you're getting conflicts, not failing
dependencies. See if you have old kernel packages hanging around, and if so,
uninstall them; I needed to do this once too, after which I could install the
latest initscripts. Don't forget to remove the uninstalled kernel from lilo.conf
and to rerun lilo. Once you have upgraded the initscripts, the old kernel would
be quite useless anyway (I tried this). You may want to upgrade some other core
utilities together with initscripts as well, even if not required by a
dependency, for instance modutils (see bug 7343); a mix of new and old stuff has
not always been well tested at RedHat.

Comment 4 Bill Nottingham 1999-12-01 16:35:59 UTC
Oh, by 'latest' rpm I meant 'latest stable'; the one that
shipped with 6.1 should suffice.

Comment 5 Cristian Gafton 2000-01-04 22:25:59 UTC
Assigned to dledford

Comment 6 Cristian Gafton 2000-01-04 22:27:59 UTC
Assigned to dledford