Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 74320

Summary: Static routes cannot be added easily anymore
Product: [Retired] Red Hat Linux Reporter: Jos Vos <jos>
Component: initscriptsAssignee: Bill Nottingham <notting>
Status: CLOSED CURRENTRELEASE QA Contact: Brock Organ <borgan>
Severity: high Docs Contact:
Priority: high    
Version: 8.0CC: chris.ricker, rvokal, simon.matter
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-11-12 06:40:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jos Vos 2002-09-20 12:28:17 UTC
Description of Problem:
The ifup-routes scripts does *not* look at the network-scripts/route-$DEVICE
file anymore, *unless* a file networking/devices/$DEVICE.route exists.  This
makes it very difficult to easily add manual static routes by just putting them
in a file, like static-routes or route-$DEVICE.

Version-Release number of selected component (if applicable):
6.95-1

Workaround (only done a few tests):
Touch the networking/devices/$DEVICE.route, so that
network-scripts/route-$DEVICE is interpreted correctly.

Proposed fix:
Process the network-scripts/route-$DEVICE file before the
networking/devices/$DEVICE.route file is processed.

Comment 1 Bill Nottingham 2002-11-12 06:40:19 UTC
*** Bug 76619 has been marked as a duplicate of this bug. ***

Comment 2 Bill Nottingham 2002-11-12 06:40:22 UTC
*** Bug 75604 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2002-11-12 06:42:08 UTC
Fixed in CVS, will be in 6.96-1

Comment 4 Bill Nottingham 2003-01-27 17:47:07 UTC
*** Bug 82834 has been marked as a duplicate of this bug. ***