Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 7426

Summary: Mixer settings not loaded correctly by /etc/rc.d/rc.sysinit
Product: [Retired] Red Hat Linux Reporter: Scott C. Karlin <scott>
Component: initscriptsAssignee: Bill Nottingham <notting>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-11-29 23:46:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Scott C. Karlin 1999-11-29 23:32:22 UTC
There seems to be a bug in /etc/rc.d/rc.sysinit mixer load.
1.  The "if" statement syntax is wrong and will never be true.
2.  Since the action was directed to /dev/null, it would never display.

From initscripts-4.68-1.i386.rpm (rc.sysinit):
# Load mixer settings
if [ grep -q "14 sound" /proc/devices 2>/dev/null -a -f /etc/.aumixrc -a -x
/bin/aumix-minimal ]; then
        action "Loading mixer settings" /bin/aumix-minimal -f /etc/.aumixrc
-L >/dev/null
fi


This should be:
# Load mixer settings -- fixed by SCK 11/29/1999
if grep -q "14 sound" /proc/devices 2>/dev/null && [ -f /etc/.aumixrc -a -x
/bin/aumix-minimal ]; then
        action "Loading mixer settings" /bin/aumix-minimal -f /etc/.aumixrc
-L
fi

Comment 1 Bill Nottingham 1999-11-29 23:46:59 UTC
*** This bug has been marked as a duplicate of 7366 ***