Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 7325

Summary: Default gateway problems when using dialup & LAN together
Product: [Retired] Red Hat Linux Reporter: Rob Soulier <r.j.m.soulier>
Component: initscriptsAssignee: Michael K. Johnson <johnsonm>
Status: CLOSED ERRATA QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-11-30 15:45:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Rob Soulier 1999-11-25 12:00:40 UTC
In my case I have configered my laptop for a LAN with a router (which is my
default gateway) for when I'm at my office, and a dialup PPP connection via
/dev/ttyS0 and my ISDN adapter to my ISP for when I'm elswhere e.g. at
home. When no LAN was configured PPP was fine. Since my LAN was configured
(with a default gateway) PPP gave me a connection that wouldn't work.
Debug told me PPP could not change the default gateway (although this
option was used). I found that this is solved by placing the call to pppd
in a wrapper script that does a 'route del -net 0.0.0.0 gw router-ip'
before calling pppd, and a 'route add default gw router-ip' after
disconnecting and stopping pppd. With de default gateway on eth0 out of the
way, pppd is able to establish the PPP peer as default gateway.
I don't know if this is a bug or a feature (or a user error), but this
behaviour (if a feature) might be doumented e.g. in the ppp-faq.
There is already another problem report on default gateways & ppp, with
another cause.

Regards,

Rob

Comment 1 Michael K. Johnson 1999-11-30 15:45:59 UTC
Please update to the latest initscripts.