Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 7318

Summary: halt does poweroff too.
Product: [Retired] Red Hat Linux Reporter: Ric Anderson <azric47>
Component: SysVinitAssignee: Bill Nottingham <notting>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: rvokal
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-04-19 20:23:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Ric Anderson 1999-11-25 04:50:38 UTC
/sbin/halt with no parameters, e.g.
	# /sbin/halt
causes a power off as though -p or the poweroff command was used.  This
is because halt execs shutdown which execs "init 0" which runs the
scripts in rc0.d, and the last of those (S01halt) contains a
"halt -i -d -p".

Obviously I can edit S01halt to eliminate the -p.  But this makes the
poweroff command equivalent to a halt (no power off occurs).

Is there some way to make halt just halt the machine, and still
have poweroff (or halt -p) shut off power?

Comment 1 Bill Nottingham 1999-11-29 16:39:59 UTC
Since halt now calls init to switch to runlevel 6, it's
difficult to get arguments passed in the environment
to it. We'll look into patching halt to do this.

Comment 2 Bill Nottingham 2000-04-19 20:23:59 UTC
Fixed in initscripts-5.10-1, and SysVinit-2.78-8.