Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 7287

Summary: initscripts-4.67/rc.d/rc.sysinit cannot use loadkeys
Product: [Retired] Red Hat Raw Hide Reporter: Olivier Baudron <olivier.baudron>
Component: console-toolsAssignee: Bill Nottingham <notting>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0CC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-01 23:42:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Olivier Baudron 1999-11-24 13:15:35 UTC
Line 121 in initscripts-4.67/rc.d/rc.sysinit:
  loadkeys $KEYMAP < /dev/tty0 > /dev/tty0 2>/dev/null && \

Since loadkeys uses shared object from /usr/lib it fails.
Maybe it is a bug in console-tools-19990829-1.i386.rpm which installs
loadkeys in /bin but installs libconsole.so in /usr/lib.

Comment 1 Bill Nottingham 2000-02-01 23:42:59 UTC
This is fixed in the console-tools in Raw Hide.