Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 72633

Summary: text going out of the margin boundaries
Product: [Retired] Red Hat Linux Reporter: Jens Knutson <jensk.maps>
Component: abiwordAssignee: Caolan McNamara <caolanm>
Status: CLOSED CURRENTRELEASE QA Contact: Mike McLean <mikem>
Severity: high Docs Contact:
Priority: medium    
Version: 8.0CC: bwcary, diranda, havardw, hippytrail, jsmith.fedora, otaylor, sean.redmond, sflory, webmaster
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-01-07 08:42:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Description Flags
Screenshot to show WTF I'm talking about ;-)
Running Dia with ISO-8859-1
Running Dia with UTF-8 none

Description Jens Knutson 2002-08-26 06:42:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
This is a strange one, but I hope I describe it well...

In Abiword, when typing out the first line of a sentance, when I reach the
rightmost margin of the page, it keeps typing beyond the edge of the margin.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Type a line in Abiword that hits the end of the right hand margin
2. Keep typing and watch it keep trailing past the edge of the margin
Additional info:

I've tried this on multiple machines, one with a Matrox G400, and the other 2
with ATI cards, so it doesn't *seem* to be an X driver bug...

Marking as High because without this getting fixed, Abi is basically useless.

Comment 1 Jens Knutson 2002-08-26 06:43:45 UTC
Created attachment 72944 [details]
Screenshot to show WTF I'm talking about ;-)

Comment 2 Samuel Flory 2002-09-08 22:17:06 UTC
  I'm seeing this issue as well.

Comment 3 Jeremy Katz 2002-09-20 21:10:12 UTC
*** Bug 74218 has been marked as a duplicate of this bug. ***

Comment 4 Jeremy Katz 2002-09-20 21:11:07 UTC
Okay, seems to be related to UTF-8 locales.  Looking at it a little more to see
how to fix it properly.

Comment 5 Håvard Wigtil 2002-10-02 14:04:14 UTC
It's also present in 8.0, and it also affetcs Dia.
Workaround: set locale to a ISO-8859-1 one ("LANG=en_GB.ISO-8859-1 dia").

I'm attaching two screenshots, one with LANG=en_GB.UTF-8 and one with

Comment 6 Håvard Wigtil 2002-10-02 14:05:21 UTC
Created attachment 78086 [details]
Running Dia with ISO-8859-1

Comment 7 Håvard Wigtil 2002-10-02 14:06:22 UTC
Created attachment 78087 [details]
Running Dia with UTF-8

Comment 8 Kenneth Rawlings 2002-10-11 18:21:50 UTC
*** Bug 75217 has been marked as a duplicate of this bug. ***

Comment 9 Need Real Name 2002-10-15 13:45:20 UTC
I've also tried upgrading to version 1.3 of Abiword with Abiword's RPM (Redhat
8.0 ships with Abiword 1.2) and that did not solve word wrap issue.

Comment 10 Jeremy Katz 2002-10-30 20:00:43 UTC
*** Bug 76941 has been marked as a duplicate of this bug. ***

Comment 11 Jeremy Katz 2002-12-29 09:01:18 UTC
*** Bug 79596 has been marked as a duplicate of this bug. ***

Comment 12 Jeremy Katz 2002-12-29 19:02:31 UTC
Worked around for 1.0.3-1 by making the locale non-utf8 in the abiword wrapper
script.  Abiword 1.1.x handles this better but isn't yet ready for release.

Comment 13 Evan Clarke 2003-02-15 12:38:41 UTC
Just letting people know that I am seeing this as well - and it is making using
Abiword/Dia quite fruitless task.

I am running RH 8.0 will all updates installed - a fairly standard install
(aside from the MS core fonts and the Mozilla 1.3B RPMs).

Is there a work around (comment #12 seemed to have something that may work - but
I am afraid that I do not know what he means) - or (preferably) an updated RPM
to install.

This does seem like quite a common problem (google searching lead to lots of
people asking but no solutions) that is still affecting people.

Is there anything that I can do to help (do tests/etc)?  This really does need
to be solved.

Comment 14 Keith 2003-02-18 19:46:39 UTC
 Jeremy Katz writes:

>Worked around for 1.0.3-1 by making the locale non-utf8 in the abiword wrapper

Where is the wrapper script?