Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 7256

Summary: /usr/include/ndbm.h missing
Product: [Retired] Red Hat Linux Reporter: Andreas Luik <andreas.luik>
Component: glibcAssignee: Cristian Gafton <gafton>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-01-05 00:22:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Andreas Luik 1999-11-23 16:06:56 UTC
The include file <ndbm.h> (/usr/include/ndbm.h) is missing from
RedHat 6.1.  It was available on RedHat 5.1 in glibc-devel-2.0.7-29.
Its absence makes it more difficult to compile programs which
use NDBM, because the <ndbm.h> include file is kind of a
"standard" one.

Note: ndbm.h header files are available in several other places:

taylor:~(32)> locate ndbm.h
/usr/i386-glibc20-linux/include/ndbm.h
/usr/include/db1/ndbm.h
/usr/include/gdbm/ndbm.h

Probably the easies fix is to add a symbolic link from
/usr/include/ndbm.h to /usr/include/db1/ndbm.h.

--
Andreas Luik         E-Mail: luik@orthogon.de / luik@isa.de
Orthogon GmbH        WWW:    http://www.orthogon.de/~luik
Sys/Net Admin        PGP:    E2 6A 41 70 67 1E 0B 68  94 0D 9E 83 95 16 AF
59

Comment 1 Cristian Gafton 2000-01-05 00:22:59 UTC
use
   #include <db1/ndbm.h>

This is because glibc 2.1 switches to db2 as the default DB library and NDBM is
really a db1-type interface.