Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 72045

Summary: redhat-config-soundcard-0.9.9-3: fails to detect CS4236 chip
Product: [Retired] Red Hat Linux Reporter: Joachim Frieben <jfrieben>
Component: redhat-config-soundcardAssignee: Brent Fox <bfox>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: gt, josh, p.van.egdom
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-09-07 15:48:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Joachim Frieben 2002-08-20 21:06:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
Does not detect the on-board CS4236 sound system of my PR440FX based dual
Pentium Pro workstation.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Launch "redhat-config-soundcard".

Actual Results:  The message "No soundcards were detected" is issued.

Expected Results:  "redhat-config-soundcard" should detect and configure the
CS4236 sound chip correctly.

Additional info:

After installing "sndconfig-0.68-4", the latter detects the CS4236 sound chip
immediately and produces a functional "/etc/modules.conf" file.

Comment 1 Dr. Peter Boy 2002-08-23 09:39:44 UTC
Same problem here with a cs 4232

During installation the card seems to be miss-identified. In modules.conf you
find right after installation:
   alias sound-slot-1 ad1848
   post-install sound-slot-1 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null
2>&1  || :
   pre-remove sound-slot-1 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null
2>&1 || :

and nothing else regarding sound.

Good old sndconfig of beta null (sndconfig-0.68-4) detects the card and
configures it . modules.conf afterwards:
   alias sound-slot-0 cs4232
   post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null
2>&1 || :
   pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null
2>&1 || :
   options sound dmabuf=1
   alias synth0 opl3
   options opl3 io=0x388
   options cs4232 isapnp=1

/proc/isapnp just after installation finished:
Card 1 'CSCe825:Crystal Audio' PnP version 1.0 Product version 0.1
  Logical device 0 'CSC0100:WSS/SB'
    Device is not active                 # ## (because driver not loaded)
    Resources 0
      Priority preferred
      Port 0x534-0x534, align 0x3, size 0x4, 16-bit address decoding
      Port 0x388-0x388, align 0x7, size 0x4, 16-bit address decoding
      Port 0x220-0x220, align 0x1f, size 0x10, 16-bit address decoding
      IRQ 5 High-Edge
      DMA 1 8-bit byte-count compatible
      DMA 0,3 8-bit byte-count compatible
      Alternate resources 0:1
      ......  (more alternatives)

and in /etc/sysconfig/hwconf:

class: UNSPEC
detached: 0
driver: ns558
desc: "Crystal Audio:CTRL"
deviceId: CSC0110
pdeviceId: CSCe825
native: 1
active: 0
cardnum: 0
logdev: 2

          and some lines later:

class: AUDIO
detached: 0
driver: cs4232
desc: "Crystal Audio:Disabled"
deviceId: CSC010f
pdeviceId: CSCe825
native: 0
active: 0
cardnum: 0
logdev: 1
class: AUDIO
detached: 0
driver: ad1848
desc: "Crystal Audio:WSS/SB"
deviceId: CSC0100
pdeviceId: CSCe825
native: 1
active: 0
cardnum: 0
logdev: 0

Comment 2 Peter van Egdom 2002-08-29 19:57:52 UTC
A similar situation here. I've got a Creative SB AWE64 Gold (ISA card) in
a Red Hat Linux 'null' machine here.

"redhat-config-soundcard" didn't find it ('no soundcards were detected').

"sndconfig" did find the card. After some questions the following modules were
inserted by sndconfig :

awe_wave              170912   0  (unused)
sb                      9332   0 
sb_lib                 44526   0  [sb]
uart401                 8452   0  [sb_lib]
sound                  73780   0  [awe_wave sb_lib uart401]
soundcore               6500   6  [sb_lib sound]

On previous installations - e.g. Red Hat Linux 7.3 - sound always worked
without any trouble.

Comment 3 Peter van Egdom 2002-08-29 19:59:49 UTC
(forgot to mention : tried "redhat-config-soundcard-1.0.1-1")

Comment 4 Need Real Name 2002-09-07 15:48:20 UTC
I've got a dell latitude Cpi D300 XT, sndconfig on RH7.3 and null, don't 
find the sound card, but suggest using soundblaster. 
I also installed sndconfig and got it working on the beta version 
by accepting soundblaster. 

Comment 5 Brent Fox 2002-11-22 18:01:55 UTC
Right, sndconfig had the ability to handle some ISA cards, while
redhat-config-soundcard only handles PCI cards at the moment.

I don't have any current plans to handle ISA cards in redhat-config-soundcard. 

Comment 6 Brent Fox 2002-11-22 18:27:01 UTC
*** Bug 75014 has been marked as a duplicate of this bug. ***

Comment 7 Brent Fox 2002-11-22 18:27:45 UTC
*** Bug 77052 has been marked as a duplicate of this bug. ***

Comment 8 Brent Fox 2002-11-22 18:52:12 UTC
*** Bug 77466 has been marked as a duplicate of this bug. ***

Comment 9 Brent Fox 2002-11-22 20:03:04 UTC
*** Bug 72802 has been marked as a duplicate of this bug. ***

Comment 10 Aric Blumer 2002-11-25 13:52:30 UTC
Only handling PCI cards?  One of Linux's strong points is its use on older
machines.  Windows supports these sound cards seamlessly--in order to compete,
you do, too. (BTW, my dell machine that exhibits this problem is not that old.)

Comment 11 Aric Blumer 2002-11-25 15:50:13 UTC
One more thing that needs to be added here. This is more than a configuration
problem.  You cannot control the volume either with the gnome-volume-control
app, even after you configure it with the TUI app.

Comment 12 Brent Fox 2002-11-26 16:19:21 UTC
aric, I'm not saying that redhat-config-soundcard will never support ISA cards.
 I'm just trying to be honest about what I can realistically accomplish in the
time between now and the next release.

I can't explain why the gnome-volume-control doesn't work for you.  I don't
think that has to do with redhat-config-soundcard, however.

Comment 13 Brent Fox 2002-12-18 21:25:06 UTC
*** Bug 79061 has been marked as a duplicate of this bug. ***

Comment 14 Brent Fox 2003-01-02 18:00:17 UTC
*** Bug 80944 has been marked as a duplicate of this bug. ***

Comment 15 Cliff Olmsted 2003-01-06 12:26:25 UTC
Just my $0.02, I just installed 8.0 and it failed to configure my SB16 ISA card!
 IMO this really needs to be Mom would never have found the solution
to this problem :)  Seriously, can a work around using sndconfig during initial
install be created as a temporary kludge until redhat-config-soundcard is up to

Comment 16 Brent Fox 2003-01-14 22:34:38 UTC
snconfig is there if you want to run it.  Or at least it should be.