Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 7204

Summary: silo won't boot large partition
Product: [Retired] Red Hat Linux Reporter: Jeff Shao <shaoj>
Component: siloAssignee: Jakub Jelinek <jakub>
Status: CLOSED NOTABUG QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: sparc   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-12-14 01:37:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jeff Shao 1999-11-21 18:59:31 UTC
RedHat 6.0 Sparc will install and boot my default 2.0GB root partition.

After upgrading to 6.1 sparc, it says Buggy Old PROMs..

I had to create a smaller root partition (~1GB).

Why did it work on previous versions of Sparc/Linux.. but not 6.1

thanks

Comment 1 Joshua Uziel 2000-03-17 10:56:59 UTC
It depends on what version PROM your SPARC has.  All UltraSPARCs are capable
of booting from any size partitions... but the sun4m's or sun4c's can only
boot from the first 1GB or 2GB, depending on the version.

As an example, I have an SS10 that used to have an older PROM only capable
of booting from the first 1GB... but I have a 4GB disk.  I did an install of
RH 6.0 on it and it booted fine while I was using little of the disk.  Then
I went and copied a pair of CD ISO images to my machine and later built a new
kernel and the machine wouldn' boot anymore.  Why not?  Because the new image
was on the disk past the first gig somewhere.

So, that limitation is for you protection...