Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 7200

Summary: disk druid partition allocation failure, reason undefined
Product: [Retired] Red Hat Linux Reporter: bill.cooksey
Component: installerAssignee: Jay Turner <jturner>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-11-22 15:00:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description bill.cooksey 1999-11-21 14:17:28 UTC
I'm trying to install 6.1 on an IDE drive, which is the slave on the
second IDE interface (hdd). I've tried various approaches and it doesn't
seem to matter. For example, using the GUI and Custom install, I get to
the disk druid window and can add a swap partition but then if I add a
root partition I get the unallocated partions errorbox with: "/    Reason
Undefined". Leaving that be, if I then add a /boot partition, sometimes,
the root partition appears to magically become allocated but the /boot
partition is unallocated with the same Undefined reason.

As I said, the hard drive is IDE2, Slave. The CDROM is IDE2, Master. I've
tried both of the following geometries; 4960/16/63 and 620/128/63. It's a
WDC drive with 2441MB (2560 million bytes).

It's also worth noting that if I try a workstation install that
AutoPartitioning fails.

Thanks for your help. I'm stuck

Bill

Comment 1 Jay Turner 1999-11-22 15:00:59 UTC
Disk Druid is trying to be "smart" and only allow the /boot partition to be
placed on /dev/hda, as this is the only drive that most BIOSes can boot.
Anyway, the workaround for this problem is that you will want to install in
"expert" mode (type "expert" at the boot prompt) and then create the partitions
in fdisk.  You will then be able to tell the system which partition to use for
/boot and the other partitions, without having to worry about the installer
second-guessing you.