Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 7157

Summary: autopasswd (part of expect) non-functional
Product: [Retired] Red Hat Linux Reporter: rtowster
Component: tcltkAssignee: Jens Petersen <petersen>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-03 20:24:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description rtowster 1999-11-19 21:42:20 UTC
I fixed this myself in RH 5.0.. and now again in 6.0.. maybe you can fix it
for 7.0.. Anyway.. here is a fixed one...
----------------------
#!/usr/bin/expect -f
# wrapper to make passwd(1) be non-interactive
# username is passed as 1st arg, passwd as 2nd

set force_conservative 1
set password [lindex $argv 1]
spawn passwd [lindex $argv 0]
sleep .1
expect "password:"
sleep .1
send "$password\r"
sleep .1
expect "password:"
sleep .1
send "$password\r"
sleep .1
expect eof

Comment 1 Elliot Lee 2000-02-03 20:24:59 UTC
Change is in tcltk-8.0.5-33