Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 7139

Summary: Lock file is not removed after killing
Product: [Retired] Red Hat Linux Reporter: Vsevolod Volkov <home>
Component: dipAssignee: Michael K. Johnson <johnsonm>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-11-22 18:19:42 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Lock patch none

Description Vsevolod Volkov 1999-11-19 13:12:47 UTC
Lock file is not removed after killing. Perhaps it's due to
some kind of debug code. Here is patch:

--- dip-3.3.7o/tty.c.lock   Mon Nov 15 22:13:23 1999
+++ dip-3.3.7o/tty.c        Mon Nov 15 22:13:57 1999
@@ -885,3 +885,3 @@
 {
-#if 0
+#if 1
   return(tty_mode);

Comment 1 Vsevolod Volkov 1999-11-19 13:13:59 UTC
Created attachment 7 [details]
Lock patch

Comment 2 Michael K. Johnson 1999-11-22 18:19:59 UTC
Fixed in dip-3.3.7o-16, which will be in the next RawHide.