Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 7099

Summary: klock problem with ypbind
Product: [Retired] Red Hat Linux Reporter: Udo Jocher <udo>
Component: kdebaseAssignee: Bernhard Rosenkraenzer <bero>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-18 11:52:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Udo Jocher 1999-11-18 13:21:01 UTC
Users, which account information is obtained by ypbind from another
machine, locking the terminal with klock are not able to unlock the
terminal. Giving the correct password, klock says "failed".
Users with a local account don't have this problem.

Comment 1 Bernhard Rosenkraenzer 1999-11-21 12:15:59 UTC
Please check your PAM settings (/etc/pam.d/kde) and version.
Looks like a misconfiguration.

Comment 2 Udo Jocher 1999-11-22 18:06:59 UTC
My PAM settings are (/etc/pam.d/kde)
#%PAM-1.0
auth       required     /lib/security/pam_pwdb.so shadow nullok
auth       required     /lib/security/pam_nologin.so
account    required     /lib/security/pam_pwdb.so
password   required     /lib/security/pam_cracklib.so
password   required     /lib/security/pam_pwdb.so shadow nullok use_authtok
session    required     /lib/security/pam_pwdb.so
session    optional    /lib/security/pam_console.so

My PAM version is pam-0.68-8

Comment 3 Bernhard Rosenkraenzer 2000-02-18 11:52:59 UTC
Should be fixed in the current version.