Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 7068

Summary: /boot/kernel.h shouldn't be modified if it is unchanged
Product: [Retired] Red Hat Linux Reporter: Jonathan Kamens <jik>
Component: initscriptsAssignee: Bill Nottingham <notting>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: jik, rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-11-17 17:43:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jonathan Kamens 1999-11-17 01:35:54 UTC
/etc/rc.d/rc.sysinit regenerates /boot/kernel.h every time the machine
reboots.  This means that every time you run "gmake" in a kernel tree after
a reboot, lots of files will be rebuilt because they depend on
/boot/kernel.h (which is included by version.h), even though its content
hasn't really changed.

rc.sysinit should generate kernel.h in a temporary file, then compare it to
the one that's already there; if it's different, it should replace the old
one, but if it's the same, the temporary file should be removed and the old
kernel.h should be left in place.

Comment 1 Bill Nottingham 1999-11-17 17:43:59 UTC
Fixed in initscripts-4.65-1, which will be in the next Raw Hide release.

Comment 2 Bill Nottingham 1999-11-17 17:44:59 UTC
Fixed in initscripts-4.65-1, which will be in the next Raw Hide release.