Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 7014

Summary: wrong module for DEC 21142/43 in pcitable
Product: [Retired] Red Hat Linux Reporter: langod
Component: kudzuAssignee: Bill Nottingham <notting>
Status: CLOSED RAWHIDE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.1CC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-11-15 19:14:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description langod 1999-11-15 16:00:04 UTC
There is a wrong driver/module in pcitable for DEC 21142/43 network card:
Currently it is tulip but should be de4x5, here is the diff:

174c174
< 0x1011	0x0019	"tulip"	"DEC|DECchip 21142/43"
---
> 0x1011	0x0019	"de4x5"	"DEC|DECchip 21142/43"

if you check in /usr/src/linux/Documentation/networking/
de4x5.txt tulip.txt
you can see that de4x5 is a better choice for 21142/43 dec network cards.

ciao

Damjan (langod@hermes.si)

Comment 1 Bill Nottingham 1999-11-15 17:00:59 UTC
Hmm... I'm not sure that that docummentation is particularly relevant; it's
more than a year out of date.

Does the de4x5 driver work for you where the tulip does not?

Comment 2 langod 1999-11-15 17:34:59 UTC
Yes, the de4x5 works for me fine.
also kudzu configured the device correctly with modified pcitable.
Regarding kernel documentation, if you search for:

grep 2114 de4x5.txt tulip.txt

de4x5.txt:	DC21140[A]
de4x5.txt:	DC21142
de4x5.txt:	DC21143
de4x5.txt:    all  cards running the dc2114x  series chips in particular.  Cards
using

tulip.txt:|     EtherPower 10/100 PCI(9332DST)  |21140      |Pentium/UDB  |
tulip.txt:|     EtherWorks 100/10 PCI(DE500-XA) |21140      |Pentium      |
tulip.txt:|     LA100PCI-T                      |21140      |Pentium/UDB  |
tulip.txt:|     EM110                           |21140      |Pentium      |

I think this is clear enough that tulip is not the right choice.

Comment 3 Bill Nottingham 1999-11-15 17:40:59 UTC
The tulip.txt file hasn't been updated in a year and a half -
using it as a definitive list of the cards that it supports probably isn't
a good idea.

Does the tulip driver fail in some way that the de4x5 driver works?

Comment 4 langod 1999-11-15 18:09:59 UTC
Yes the documentation files are old, but also the source code
tulip.c is much older than de4x5.c:

last change in de4x5.c:
      0.544   8-May-99    Fix for buggy SROM in Motorola embedded boards using

last change in tulip.c:
 static const char version[] = "tulip.c:v0.89H 5/23/98
becker@cesdis.gsfc.nasa.gov\n";

Why do you insist that this is not a problem?
de4x5 works tulip does not work for my card.
That's all I can say.

Comment 5 Bill Nottingham 1999-11-15 19:14:59 UTC
OK, that's the information I wanted (that the tulip did *not* work.)

Of course, it probably will work with the 0.91 driver. Fun.
Fixed in CVS, will make its way into the next kudzu release.