Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 7008

Summary: choice of display manager is tied to choice of desktop
Product: [Retired] Red Hat Linux Reporter: Bert de Bruijn <bob>
Component: gdmAssignee: Preston Brown <pbrown>
Status: CLOSED NOTABUG QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-11-23 15:54:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Bert de Bruijn 1999-11-15 09:42:25 UTC
/etc/X11/prefdm chooses a display manager according to the desktop
preference in /etc/sysconfig/desktop
I need remote XDMCP features, and therefore I run xdm (because gdm doesn't
support indirects (etc.) as well as it should). In the present
configuration, I can't choose to run a Gnome desktop and have
/etc/X11/prefdm start xdm at the same time.

I think the display manager choice should be seperated from the desktop
environment choice.

Comment 1 Preston Brown 1999-11-23 15:54:59 UTC
This is a custom configuration issue.  The choice of associating the window
manager that goes with the desktop that is chosen is what most users are
expecting by default.  If you wish, you can modify /etc/sysconfig/desktop to be
"AnotherLevel" and then use switchdesk to change your individual preferences.