Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6987

Summary: Install fails with /RedHat on ntfs or extended fat partitons
Product: [Retired] Red Hat Linux Reporter: gcollins
Component: installerAssignee: Jay Turner <jturner>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.1CC: srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-11-16 13:19:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description gcollins 1999-11-13 11:47:36 UTC
The install disks (xxx-RHEA-1999-044/045) cannot load /RedHat from either a
NTFS (on a primary partition) or fat (on an extended partition). At the
prompt for the location of /RedHat, neither partition appears as a choice.
Even if the update disk does resolve the problem, it doesn't help because
the installer won't prompt for the update disk until AFTER it's located
/RedHat!

By copying /RedHat to my existing linux root partition, I was able to get
the update disk loaded. I then tried backing up to the screen where you
select the location of /RedHat, but the install program aborted at that
point.

At the least, the installer should support loading /RedHat from a fat
filesystem on an extended partition...

Comment 1 Jay Turner 1999-11-16 13:19:59 UTC
The installer was never meant to recognize source files on an NTFS partition, so
that is not really a bug.  We know that there are problems with the extended
partitions, and it actually related to extended partitions of type "f" as
opposed to the usual type "5"  We are going to be putting together another
update which will fix this problem, but until then the easiest workaround is to
change the type of the extended partition from type "f" to type "5", upgrade
your system, and then change the partition type back to "f".

*** This bug has been marked as a duplicate of 6482 ***