Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6980

Summary: Problem with expired passwords
Product: [Retired] Red Hat Linux Reporter: phlip
Component: passwdAssignee: Nalin Dahyabhai <nalin>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: redhat-bugzilla
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-24 19:05:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description phlip 1999-11-13 03:37:19 UTC
If I do something like `chage -M 365 -d 1 -I 0 test` to force a user to
choose a new password on next login, they get a message that says 'passwd:
Only root can specify a username' and get booted when they try to log in

Comment 1 phlip 1999-11-15 04:31:59 UTC
Sorry for the bug report.  The problem appears to be the ssh version 1 daemon
calling passwd and passing it the username.  I corrected the sshd code and now
it works.

Comment 2 redhat-bugzilla 2000-01-18 17:10:59 UTC
Actually, I think this *is* a subtle and relatively easy-to-fix bug
in the passwd program itself (/usr/bin/passwd). It makes Red Hat's
passwd act unlike every other Unix' passwd -- causing, for example,
problems in sshd.

I wrote a patch for this bug, and for one bug in the Makefile, at
	http://mark.datasys.net/redhat/passwd-0.63.patch
That's against the passwd-0.63-1.src.rpm package from Red Hat 6.1.

Comment 3 Cristian Gafton 2000-05-22 15:36:59 UTC
assigned to nalin

Comment 4 Stephen John Smoogen 2003-01-24 19:05:50 UTC
Was not able to duplicate on Red Hat Linux 7.3 machine. It may be because of
different version of SSH or changes in code since 1999. Please re-open if the
problem can be found on your system, and I will try to figure out what
differences are causing a 'WORKSFORME'