Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6968

Summary: if linux is started with mem= option, create swap that big
Product: [Retired] Red Hat Linux Reporter: Joe Harrington <jhmail>
Component: installerAssignee: Jay Turner <jturner>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: 6.1CC: jilo, srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-11-16 13:21:15 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Joe Harrington 1999-11-13 01:02:38 UTC
In the install, if the user types linux mem=192M, Druid should configure a
swap that big, and the LILO configuration should list mem=192M already.

Comment 1 Joe Harrington 1999-11-16 15:18:59 UTC
Why do you dismiss this suggestion without even a comment?

The user gives some information about the system at boot, as instructed.  There
are published requirememts of swap size and kernel options to use the full
memory of the machine.  Since the user has already given the information to the
installer, the installer should follow its own recommendations when creating the
system.  If there is some technical reason why this shouldn't be, please say
so.  Otherwise, closing this suggestion without even a comment makes it sound
like you don't care to improve the installer.

--jh--

Comment 2 jilo 2000-01-17 14:52:59 UTC
Swap needs to be exactly that size? Mine is bigger (208M) and im'not happy
getting all the RAM availiable.

Ricardo

Comment 3 Joe Harrington 2000-01-17 17:19:59 UTC
No, but it needs to be at least that size.  However, since I discovered that
you no longer need the mem= argument in most cases, I'm dropping it.  Probably
that's what jturner did, though it was a bit irresponsible just to close it
without comment, and then not reply when I asked why directly.

--jh--