Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6954

Summary: Choosing which installation to upgrade didn't work
Product: [Retired] Red Hat Linux Reporter: heikki
Component: installerAssignee: Matt Wilson <msw>
Status: CLOSED RAWHIDE QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-22 16:12:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description heikki 1999-11-12 15:34:12 UTC
We wanted to upgrade an old RedHat 5.0 installation, and at the same time
use a different root partition. So, we copied whole installation from
/dev/hda2 to /dev/hdb2, sticked in a boot diskette, and tried to upgrade
over ftp (that machine did not have a CD).

Answered /dev/hda to the question which one to upgrade.

All went smoothly, until we were informed that we didn't have enough disk
space (on a 1500M partition, filled with about 900M of the old
installation). (I report the disk size calculations as a separate bug)

Tried to delete stuff we were sure wouldbe reinstalled, and nothing helped.
Turned out that the install was trying to put things on hdb2. It had
mounted /dev/hdb2 as /mnt/sysimage(?)/ and hda2 as /mnt/sysimage/a2.

In the end we Fdisk'd /dev/hdb2 into an empty partition, so that the
installer would not find it, and would be forced to upgrade hda2. This
seemed to work, but we hit the disk size problem again, and had to stop for
today. Fdisk-created hd2 to Linux again, fsck'd it, and booted back to
normal.

Comment 1 Jay Turner 1999-11-29 20:09:59 UTC
This issue has been forwarded to a developer for further action.

Comment 2 Jay Turner 2000-02-22 16:12:59 UTC
This issue is resolved in the latest cut of the installer.