Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6940

Summary: Outdated tulip driver
Product: [Retired] Red Hat Linux Reporter: Chris Ricker <chris.ricker>
Component: kernelAssignee: Cristian Gafton <gafton>
Status: CLOSED DEFERRED QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-11-15 16:28:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Chris Ricker 1999-11-12 06:10:16 UTC
The tulip driver shipped with the kernel in 6.1 doesn't work with some
newer clones (it failed on a Macronix (PMAC) card--the card is found, the
driver loads, but it fails to establish a link).  Upgrading to 0.91g from
Donald Becker's web page fixes that problem.

Comment 1 Bill Nottingham 1999-11-15 16:28:59 UTC
Unfortunately, the newer driver breaks some of the older cards.
We're looking into ways to solve this.

Comment 2 Chris Ricker 1999-11-16 15:10:59 UTC
Yeah, I know.  So far the best idea I've had is to install both drivers.  Call
one tulip.o, and the other tulip-0.91.o, or whatever.  Go ahead and alias the
tulip.o by default, but have the other one there and alternatively insmod'able
(during install, if you're doing the install via net) / alias'able (after the
system is up and running).  The main problem is that, without the new driver
installed, people are in the Catch-22 of needing the new driver so they can get
the new driver (or vice-versa for old real Tulips if you default to the new
tulip driver).  If one's not going to work for everything, that's fine as long
as you document it, but have the other one around *somewhere* so that people who
are going to need it can have it.

Alternately, you could do a couple of *really* ugly things, like ask the person
which tulip driver to use during the install, or else leave tulip-0.89 in as the
tulip driver, and hack the tulip-0.91 in as pnic.o, and make tulip.o only
recognize older cards and pnic.o recognize all the newer almost-but-not-quite
tulip clones.

Comment 3 Bill Nottingham 1999-11-16 16:14:59 UTC
Actually, there's a tulip driver disk available at
people.redhat.com/notting/tulip

You can boot the installer with 'linux dd' and it will use this driver
instead. Unfortunately, I've yet to hear any confirmation that the driver
disk works, so I can't release it more generally yet....

Comment 4 Chris Ricker 1999-11-22 05:08:59 UTC
Stupid me--I forgot RH had the supplemental driver disk option (certainly a lot
more elegant than what Debian's talked about doing for that card, which is an
entire separate package a la pcmcia-cs drivers ;-).  At any rate, I've tried the
supplemental driver disk on three machines, and it worked on all of them.  One
suggestion:  "rename" it.  In the modinfo file right now, you've got

DEC 21040, most 21*40 Ethernet

which is the same name as the other driver.  That means both show up on the
list, and people have to guess by order which one is which....  Other than that,
it seemed good to go.

Comment 5 Pekka Savola 1999-11-22 14:48:59 UTC
I'd like to add something to the discussion too.  We have some tulip clones
here, and the old 0.89H breaks their speed/duplexity if you don't use
autonegotiation.

It's impossible to get 100/ Full-Duplex without modifying the driver and
recompiling it.  Passing relevant options (options=5 full_duplex=1) when
loading the module don't work.

This is only caused by some tulip chips, it seems.  All these problems were
fixed when we moved to 0.91.  I really hope that version would come in the
distribution in at least _some_ form.

Has Donald Becker / tulip-devel mailing list been notified about the driver
problems (concerning older tulip cards) ?