Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 69205

Summary: rpm -V up2date prints too much junk.
Product: [Fedora] Fedora Reporter: Aleksey Nogin <aleksey>
Component: up2dateAssignee: Adrian Likins <alikins>
Status: CLOSED CURRENTRELEASE QA Contact: Jay Turner <jturner>
Severity: low Docs Contact:
Priority: medium    
Version: 1CC: gafton, mihai.ibanescu, srevivo, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: 4.3.19-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-06-01 05:49:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 100644    

Description Aleksey Nogin 2002-07-18 22:29:41 UTC
The first time up2date is run it seems to modify a lot of .pyc files. After that
rpm -V updates prints:

SM5....T   /usr/share/rhn/up2date_client/bootloadercfg.pyc
SM5....T   /usr/share/rhn/up2date_client/checkbootloader.pyc
SM5....T   /usr/share/rhn/up2date_client/config.pyc
SM5....T   /usr/share/rhn/up2date_client/depSolver.pyc
SM5....T   /usr/share/rhn/up2date_client/gpgUtils.pyc
SM5....T   /usr/share/rhn/up2date_client/hardware.pyc
SM5....T   /usr/share/rhn/up2date_client/headers.pyc
SM5....T   /usr/share/rhn/up2date_client/iutil.pyc
SM5....T   /usr/share/rhn/up2date_client/lilo.pyc
SM5....T   /usr/share/rhn/up2date_client/lilocfg.pyc
SM5....T   /usr/share/rhn/up2date_client/packageList.pyc
SM5....T   /usr/share/rhn/up2date_client/rhnChannel.pyc
SM5....T   /usr/share/rhn/up2date_client/rhnDefines.pyc
SM5....T   /usr/share/rhn/up2date_client/rhnErrata.pyc
SM5....T   /usr/share/rhn/up2date_client/rhnHTTPlib.pyc
SM5....T   /usr/share/rhn/up2date_client/rhnHardware.pyc
SM5....T   /usr/share/rhn/up2date_client/rhnPackageInfo.pyc
SM5....T   /usr/share/rhn/up2date_client/rpcServer.pyc
SM5....T   /usr/share/rhn/up2date_client/rpmSource.pyc
SM5....T   /usr/share/rhn/up2date_client/rpmUtils.pyc
SM5....T   /usr/share/rhn/up2date_client/translate.pyc
SM5....T   /usr/share/rhn/up2date_client/up2date.pyc
SM5....T   /usr/share/rhn/up2date_client/up2dateAuth.pyc
SM5....T   /usr/share/rhn/up2date_client/up2dateBatch.pyc
SM5....T   /usr/share/rhn/up2date_client/up2dateErrors.pyc
SM5....T   /usr/share/rhn/up2date_client/up2dateLog.pyc
SM5....T   /usr/share/rhn/up2date_client/up2dateMessages.pyc
SM5....T   /usr/share/rhn/up2date_client/up2dateUtils.pyc
SM5....T   /usr/share/rhn/up2date_client/wrapperUtils.pyc

Should this really be happening?

% rpm -q python rhnlib up2date up2date-gnome
python-2.2.1-10
rhnlib-0.8-2
up2date-2.9.13-7.x.9
up2date-gnome-2.9.13-7.x.9

Comment 1 Adrian Likins 2002-08-02 20:03:47 UTC
I"m not exactly sure why it does that...

investigating...

Comment 2 Adrian Likins 2002-08-21 18:00:26 UTC
As best I can tell, this is normal behaviour. The *.pyc files are being
recompiled when the app runs. 

Deffering for now, will take a look at it for the next release.

Comment 3 Aleksey Nogin 2003-01-07 01:19:13 UTC
Still there in Phoebe.

Comment 4 Aleksey Nogin 2003-01-11 00:38:30 UTC
Still there is Rawhide (up2date-3.0.40-1).

Comment 5 Adrian Likins 2003-08-06 22:33:40 UTC
3.1.x seems to have finally fixed this. Closing.

Comment 6 Aleksey Nogin 2003-09-03 09:25:31 UTC
Sorry, still there.

With Severn + up2date-3.9.20-2, I still get:

SM5....T   /usr/share/rhn/up2date_client/repoBackends/__init__.pyc
SM5....T   /usr/share/rhn/up2date_client/repoBackends/aptRepo.pyc
SM5....T   /usr/share/rhn/up2date_client/repoBackends/dirRepo.pyc
SM5....T   /usr/share/rhn/up2date_client/repoBackends/genericRepo.pyc
SM5....T   /usr/share/rhn/up2date_client/repoBackends/genericSolveDep.pyc
SM5....T   /usr/share/rhn/up2date_client/repoBackends/up2dateRepo.pyc
SM5....T   /usr/share/rhn/up2date_client/repoBackends/urlUtils.pyc
SM5....T   /usr/share/rhn/up2date_client/repoBackends/yumRepo.pyc
SM5....T   /usr/share/rhn/up2date_client/up2dateUtils.pyc


Comment 7 Aleksey Nogin 2003-10-03 20:22:27 UTC
With up2date-3.9.28-2, I still get:

SM5....T   /usr/share/rhn/actions/__init__.pyc
SM5....T   /usr/share/rhn/actions/packages.pyc
SM5....T   /usr/share/rhn/up2date_client/repoBackends/__init__.pyc
SM5....T   /usr/share/rhn/up2date_client/repoBackends/aptRepo.pyc
SM5....T   /usr/share/rhn/up2date_client/repoBackends/dirRepo.pyc
SM5....T   /usr/share/rhn/up2date_client/repoBackends/genericRepo.pyc
SM5....T   /usr/share/rhn/up2date_client/repoBackends/genericSolveDep.pyc
SM5....T   /usr/share/rhn/up2date_client/repoBackends/up2dateRepo.pyc
SM5....T   /usr/share/rhn/up2date_client/repoBackends/urlUtils.pyc
SM5....T   /usr/share/rhn/up2date_client/repoBackends/yumRepo.pyc
SM5....T   /usr/share/rhn/up2date_client/up2dateUtils.pyc


Comment 9 Aleksey Nogin 2004-01-19 09:47:16 UTC
Still there with up2date-4.3.8-1

Comment 10 Warren Togami 2004-05-06 06:49:14 UTC
I just checked in a fix for mailman that works for that similar
problem.  msw said that recipe should work for any python package.  I
would attempt to modify up2date right now, but I can't find it in the CVS.

Comment 11 petrosyan 2004-06-01 04:52:07 UTC
this bug seems to be fixed in Fedora Core 2 up2date-4.3.19-1

Comment 12 Aleksey Nogin 2004-06-01 05:49:57 UTC
Yes, indeed. Changelog shows:

* Thu May 06 2004 Warren Togami <wtogami@redhat.com>

- #69205 bytecompile for rpm -V

Thanks, Warren!