Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6905

Summary: g77/f77 problems
Product: [Retired] Red Hat Linux Reporter: kms
Component: egcsAssignee: Nalin Dahyabhai <nalin>
Status: CLOSED WORKSFORME QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-12-24 16:14:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description kms 1999-11-11 01:09:16 UTC
We have installed Red Hat 6.0 and 6.1 numerous times on
numerous machines and most of the fortran programs (that
compile nicely and run on a sun) we have compile but then
dump with a segmentation fault when run.
An ldd of the executable gives "this is not dynamically
linked". We have also installed several other f77 packages
for linux and they don't work either. Having said all that
we have 1 machine that when reinstalled with 6.0 or 6.1
consistently (and we have occasionally fluked the odd other
machine but on a 2nd installtion of RedHat fails) compiles
and runs ALL the programs but we have no idea why. Also, an
executable from a machine that doesnt work will run on the 1
good machine (P 166hz).
The one machine we really need this to work on (Dell
Notebook) continually fails (so far we have tried installing
the operating system 6.0 and 6.1 > 10 times.

Comment 1 Jim Kingdon 1999-11-22 22:50:59 UTC
Could you be more specific about what programs are having a problem?
Does it happen on short test programs?  If so, all of the ones you
tried or just some?

For example, I tried the following on a 6.1 system and it worked for me:

$ cat foo.f
      PRINT *,'Hello, world'
      END
$ f77 -g foo.f
$ ./a.out
 Hello, world
$

Also, what CPU is in the machines which don't work?

I'm not sure I can do a lot if the problem doesn't show up on my machine,
but I can see if anything springs to mind with the above information.

Comment 2 Jim Kingdon 1999-12-24 16:14:59 UTC
Changing this to WORKSFORME pending further information (as described in
my previous comment).