Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6828

Summary: ifup no longer recognizes ARP flag
Product: [Retired] Red Hat Linux Reporter: chris.studholme
Component: initscriptsAssignee: Bill Nottingham <notting>
Status: CLOSED RAWHIDE QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: 6.1CC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-11-16 17:18:58 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description chris.studholme 1999-11-08 18:56:20 UTC
Older versions of RedHat used to have "ifconfig ${DEVICE}
${IPADDR} netmask ${NETMASK} broadcast ${BROADCAST}
${ARP:+arp}" in /etc/sysconfig/network-scripts/ifup.  Newer
versions are missing the "${ARP:+arp}" part.  This is needed
by people who are using the ethertap device and want proper
ARP activity.  I can't see it effecting anyone else.

Comment 1 Bill Nottingham 1999-11-08 19:35:59 UTC
Um, how old is 'older' in this case?

I don't see any traces of this in our CVS archive... :)

Comment 2 Bill Nottingham 1999-11-16 17:18:59 UTC
added in initscripts-4.65-1, which will be in the next Raw Hide release.