Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6788

Summary: Anaconda has problems displaying some characters
Product: [Retired] Red Hat Linux Reporter: Richard Allen <ra>
Component: installerAssignee: Matt Wilson <msw>
Status: CLOSED RAWHIDE QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-04-14 20:29:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Richard Allen 1999-11-07 00:41:52 UTC
Two of the 22 Icelandic characters come out in anaconda as
filled boxes. Those two characters are valid members of
the esteemed ISO 8859-1 family.  They are "~" and "p".

Comment 1 Richard Allen 1999-11-29 17:29:59 UTC
Ive also noticed this problem on the console itself, after installation.
The problem seems to be that the font used on the console dosnt have those
two characters (and therefore not fully ISO8859-1 compliant)

Comment 2 Jay Turner 1999-11-29 21:05:59 UTC
*** Bug 6787 has been marked as a duplicate of this bug. ***This issue has been forwarded to a developer for further action.

Comment 3 Richard Allen 2000-01-17 19:21:59 UTC
I've been doing some digging on my own on this problem (use the source Luke)
and I have come to the following conclusion.

/usr/lib/kbd/consolefonts/default8x16.psf.gz is the culprit here.
it is missing the two characters in question. Not knowing how to modify .psf
fonts I cant fix the problem.  Still, we can do the following:

cp /usr/lib/kbd/consolefonts/iso01.f16.psf.gz
/usr/lib/kbd/consolefonts/default8x16.psf.gz

and be done with the problem in installed boxes.  We still need to fix this
in Anaconda during installs.

As the maintainer of the Icelandic translations of anaconda and the rest of
the tools I can show you this:

ra@xo> grep -c p install/is.po
369
ra@xo> grep -c ~ install/is.po
147

Keep in mind that that is just the installer.  More characters that appear
as boxes in specs, authconfig, chkconfig and so forth.
I consider this a very high priority bug to be fixed before 6.2 is released.

Comment 4 Richard Allen 2000-01-17 19:58:59 UTC
Did even more digging.  It's not 4 characters that are mising, but 10.
"~", "^", "p", "P", "}", "]", "A", "Z", "M" and "S"

Comment 5 Jay Turner 2000-02-22 15:37:59 UTC
Is this looking a little better in the 6.1.92 beta that we released?  Please
reopen this bug if you are still seeing problems in the beta.