Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6761

Summary: Users cannot be in more than 32 groups
Product: [Retired] Red Hat Linux Reporter: akonstam
Component: kernelAssignee: Bill Nottingham <notting>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-11-05 19:56:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description akonstam 1999-11-05 15:25:35 UTC
I am not sure if this is a bug or a feature but it looks
like in RH 6.x no user can be in more than 32 groups. If
they are put into more than 32 groups they will no longer be
able to logon to the machine. The groups capmmand will
report only 32 groups for the user.

Comment 1 Bill Nottingham 1999-11-05 16:27:59 UTC
It's a kernel limit. See /usr/include/asm/param.h.

You could in theory change this in the kernel, but
a large portion of userland may need to be recompiled because
of this.

The big effect of changing this is that you're changing the
size of the kernel's internal task strucutre, so each task will
take a little more kernel memory.