Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6718

Summary: libpcap - changes(?) break ethereal
Product: [Retired] Red Hat Linux Reporter: baz
Component: tcpdumpAssignee: Harald Hoyer <harald>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: disabled
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-12-22 13:24:11 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description baz 1999-11-04 15:09:29 UTC
Ethereal when built on 6.1 hangs in recvfrom() - the
same code compiled on 6.0 (or even 5.2) works fine on
6.1.

Comment 1 mikepery 1999-11-15 10:03:59 UTC
libpcap seems to be broken in general, and the SRPM is missing from
ftp.redhat.com, so I was unable to see what broke. It worked in 6.0, and then
suddenly in 6.1 it's not picking up packets as they come across the wire (ie it
blocks forever as if there is no network activity). Compiling libpcap 0.4 fresh
from the tar fixes the problem.

Comment 2 Anonymous 1999-11-16 08:47:59 UTC
Theres a patch available at
http://ethereal.zing.org/~gerald/libpcap-0.4-guy-gerald.patch (assuming this
problem is what you are referring to). I just started using ethereal, and this
patch apparently fixes the stalling problem according to the ethereal download
page. However, it doesn't patch to the SRPM source, so I haven't tested it.

mikepery: The libpcap RPM is built from the tcpdump SRPM.

Comment 3 Jeff Johnson 1999-12-22 13:24:59 UTC
*** This bug has been marked as a duplicate of 6773 ***