Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6660

Summary: rp3 crashes
Product: [Retired] Red Hat Linux Reporter: john
Component: rp3Assignee: Michael K. Johnson <johnsonm>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: john
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-11-19 20:57:43 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description john 1999-11-02 19:01:10 UTC
RedHat 6.1 installed on Pentium II II 400 ('/boot'
partition on first IDE drive, '/' partition on second IDE
drive - both Maxtor Diamondmax Plus 5120 20Gb drives).

I was adding the first ISP. It searched for a modem, gave
me its settings, I tried to make some manual changes and it
crashed. System message was :

rp3 has crashed due to a fatal error (segmentation fault)

After rp3 crashed I was unable to use it again - it crashed
each time I did.

John Grubb

Comment 1 Michael K. Johnson 1999-11-03 19:24:59 UTC
We released rp3-1.0.1 as an upgrade.  Can you try upgrading and see
if it helps?

You may need to remove the configuration files it created, as they
may have been corrupted by the original crash and therefore be
causing subsequent crashes.
  rm /etc/wvdial.conf /etc/sysconfig/network-scripts/ifcfg-ppp*
Then try again with rp3-1.0.1 and see if it works better for you.

Thanks!

Comment 2 Michael K. Johnson 1999-11-06 03:57:59 UTC
Again, please let me know if you can still reproduce either of
these bugs.  The first really should be fixed by rp3-1.0.1 and
I've since made the file parsing more robust, so the next release
may be able to deal with some forms of corrupt data files as well.

Thanks,

Comment 3 Michael K. Johnson 1999-11-19 20:57:59 UTC
Let me know if you can reproduce this with rp3-1.0.1.  If so, try
ftp://people.redhat.com/johnsonm/rp3/rp3-1.0.2-1.i386.rpm
and see if it works better.  I may release it, or a later version if
other bugs are found, as another errata update.