Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 666

Summary: /usr/include/bytesex.h missing
Product: [Retired] Red Hat Raw Hide Reporter: jehamby
Component: glibcAssignee: Cristian Gafton <gafton>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-01-05 21:18:37 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description jehamby 1999-01-02 01:04:43 UTC
When compiling ALSA-driver (see URL for ALSA home page), I
got numerous errors about missing bytesex.h.  It's not in
glibc-devel-2.0.108-0.981221, so I ended up copying it from
glibc-2.0.7-29 from RedHat 5.2  For your reference,
bytesex.h is a really tiny header file which looks like this
on i386:

/* i386 is little-endian.  */

#define __BYTE_ORDER __LITTLE_ENDIAN

Perhaps this is a bug in ALSA, but since this file existed
in earlier versions of glibc, you should include it if for
no other reason than backwards compatibility, right?

Comment 1 Jeff Johnson 1999-01-05 21:18:59 UTC
Use /usr/include/endian.h instead. Backward compatibiliy
for a one-line include file like this is not worth the effort.