Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6654

Summary: BUG IN DYNAMIC LINKER ld:so: dynamic_link.h:57
Product: [Retired] Red Hat Linux Reporter: ajay
Component: basesystemAssignee: Bill Nottingham <notting>
Status: CLOSED DUPLICATE QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 6.1CC: ajay, rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-12-17 22:30:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description ajay 1999-11-02 17:54:34 UTC
Install 6.1 fresh on HP Vectra XU 5/90.
1 Pentium 90 CPU, 64 MB Ram, 4.3 GB IDE, 16 MB /boot,
3900 MB / and 208 MB swap.

Selected everything to install.
After installation completed on reboot I get lot of
messages:
BUG IN DYNAMIC LINKER ld.so: dynamic_link.h 57: elf_dynamic
info assertion '! "bad dynamic tag" failed.

After login in as root tried to run 'ps' command and got
 the same error (and no output from ps command).

BUG IN DYNAMIC LINKER ld.so: dynamic_link.h 57: elf_dynamic
info assertion '! "bad dynamic tag" failed.

Tried different partioning of hard disk but still have same
problem.
Also applied all available updates (downloaded rpms), but
problem persists.

Comment 1 Bill Nottingham 1999-11-03 17:15:59 UTC
*** This bug has been marked as a duplicate of 6685 ***

Comment 2 ajay 1999-11-06 06:04:59 UTC
It was a new install of 6.1 from scratch. Did not change anything in
/etc/ld.so.conf i.e. it is as installed.
(could send you a copy later if you want).
It has a pentium 90 machine one processor (dual capable Iremoved
one of the processor before installing as 6.1 SMP kernel crashes on
it, a
diffrent problem.

The video card is actualy Diamond Stealth 64 Video 2001 (S3 Trio64V+)
which I think uses S3 86C765 chip.

Here are contents of /etc/ld.so.conf

/usr/X11R6/bin
/usr/lib
/usr/i486-linux-lib5/lib
/usr/lib/qt-2.0.1/lib
/usr/lib/qt-1.44/lib

Ajay
===================
1. I do not have any problem with X programs so I do not think 6654
   is duplicate to 6685.
2. I did ldconfig -n, even then got the same problem with "ps"
   suggesting it is not a problem related to /etc/ld.so.conf.
   I think the problem is how "ps" is compiled/linked.
   ldd wont run on /bin/ps so I did 'string /bin/ps | grep lib'
   here is what I got:

      /lib/ld-linux.so.2
      libproc.so.2.0.0
      libc.so.6
      Compiled with: libc %d, internal version %d.%d
vm_libpid,tname,majflt,minflt,m_trs,m_drs,m_size,m_swap,rss,m_share,vm
_lib,m_dt,args

   /bin/ls work file so I did same on it an got

     /lib/ld-linux.so.2
     libc.so.6
    __libc_start_main


Ajay

Comment 3 Bill Nottingham 1999-12-17 22:30:59 UTC
*** This bug has been marked as a duplicate of 6685 ***