Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6649

Summary: redhat ppp dialog box
Product: [Retired] Red Hat Linux Reporter: megan
Component: pppAssignee: Nalin Dahyabhai <nalin>
Status: CLOSED WORKSFORME QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-07 15:55:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description megan 1999-11-02 16:50:02 UTC
(1)
when i start the redhat ppp configurator, i get a dialog box
that says something about an error with SaveYourself.

When I click 'cancel' (as opposed to remove), it comes back
every 10 seconds until i quit the configurator

(2)
also ppp does not seem to be negotiating dns properly - i
get a connection to my ISP fine, and can see IP addresses,
but i cannot resolve dns names

-megan

Comment 1 Michael K. Johnson 1999-11-06 19:35:59 UTC
I cannot reproduce (1).  Can you tell me how you are trying
to start the ppp configuration tool?

(2) will be fixed in an update to initscripts once a few more
possible bugs get ironed out.  In the meantime, you can fix it
by running the command
echo 'nameserver
nameserver' >> /etc/resolv.conf
and then logging in to your ISP again.  (The buggy code will
replace existing nameserver lines but not add new ones, so
you are just adding dummy entries to get modified when you
log in.)

Comment 2 Michael K. Johnson 1999-11-19 20:56:59 UTC
(1) works for me and I didn't hear back on any more details about how you
are running it.  Reopen if you can give me those details.

(2) is fixed in the current initscripts release.

Comment 3 Michael K. Johnson 1999-11-19 21:18:59 UTC
Only happens when rp3 pops up rp3-config automatically because there are no
network interfaces on the machine.  The save yourself message (part of
session management, incidentally) non-response is from rp3 itself, not
from rp3-config, because rp3 is waiting for rp3-config to finish.  Not
sure how to fix this at the moment.  I'll think about it.

Comment 4 Nalin Dahyabhai 2000-01-31 14:10:59 UTC
I'm no longer able to reproduce the SmcSaveYourself errors, and rp3 appears to
be waiting asynchronously for rp3-config to quit now.

Comment 5 Nalin Dahyabhai 2000-02-07 15:55:59 UTC
The reporter of this bug has not responded for over three months.  I can only
assume that she has solved her problem.