Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 662922

Summary: [RHEL5.6]: default network doesn't take into account the host network
Product: Red Hat Enterprise Linux 5 Reporter: min zhan <mzhan>
Component: libvirtAssignee: Laine Stump <laine>
Status: CLOSED NOTABUG QA Contact: Virtualization Bugs <virt-bugs>
Severity: medium Docs Contact:
Priority: medium    
Version: 5.6CC: berrange, clalance, dallan, dyuan, eblake, eli, hbrock, huzaifas, Jes.Sorensen, jmccann, katzj, kxiong, llim, markmc, mjenner, mteixeira, mzhan, tcallawa, virt-maint, virt-maint, xen-maint
Target Milestone: rcKeywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 594494 Environment:
Last Closed: 2010-12-22 04:48:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 235961, 594494    
Bug Blocks:    

Comment 1 min zhan 2010-12-14 08:35:04 UTC
Both KVM and Xen can reproduce this bug. Environment are below:

RHEL5.6-Server-x86_64
kernel-2.6.18-236.el5
kvm-qemu-img-83-222.el5
libvirt-0.8.2-15.el5

kernel-xen-2.6.18-236.el5
xen-3.0.3-120.el5

Detailed steps:

1.Make sure latest libvirt installed inside both host and guest

2.start the guest vm and check libvirtd is running in both host and guest

# service libvirtd status
libvirtd (pid  1255) is running...

3. check the guest network list in libivrt

#virsh net-list --all

Make sure the default net is inactive, if not please inactive manually.

4. check the network connectivity

from host  # ping guest_ip

from guest #ping host_ip   #ping www.google.com

5. try to start default network in guest

#virsh net-start default

Actual result:
 1. step 4, host can not ping guest, guest can not ping www.google.com
 2. step 5, default can start successfully

Expected result:
1.all ping successfully
2.step 5, an error display

Comment 2 Laine Stump 2010-12-21 16:00:32 UTC
I just tried this with a RHEL5 guest running libvrit-0.8.2-15.el5, and it behaves as expected. If the guest's libvirt is configured with the same default network as the host's libvirt, when you start libvirtd in the guest, /var/log/messages will show the following message:

networkCheckRouteCollision:1110 : internal error Network 192.168.122.1/255.255.255.0 is already in use by interface eth0.

The default network on the guest libvirtd is not started, and the guest is still able to contact the outside. If I then run "virsh net-start default", I get the same error message from virsh, and the default network is still not started.

Can you please verify that:

1) the *guest* is running libvirtd-0.8.2-15.el5
2) "virsh net-dumpxml default" on the host and guest are the same
3) reboot the guest
4) verify the guest can reach the outside (eg "ping ftp.uu.net")
5) check for network connectivity in the guest, and look for the error message I mention above in /var/log/messages.
6) start libvirtd and check all that again.

If you still get the same results we need to investigate further.

Comment 3 min zhan 2010-12-22 04:48:01 UTC
(In reply to comment #2)

I tried with RHEL5.6-Server-x86_64-kvm,rc 1.0 tree. A guest running libvirt-0.8.2-15.el5. According to steps in comment 1, this bug can not be reproduced.All ping are successful in step 4, and an error will display when #virsh net-start default in guest.

So I will close this bug.