Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6565

Summary: Linuxconf generates a segmentation fault when configuring smb
Product: [Retired] Red Hat Linux Reporter: dbelliz
Component: linuxconfAssignee: Michael K. Johnson <johnsonm>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: dbelliz, hostmaster, jack
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-12-15 21:00:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description dbelliz 1999-10-31 08:31:03 UTC
I was using linuxconf to configure smb when the program
exited with a segment fault message. Next time I went into
linuxconf I was unable to view all of the the smb settings
in the right window pane.

Uninstallinnig and reinstalling the smb rpm did not corrcet
the problem.

Copied /usr/doc/samba-2.0.5a/examples/smb.conf.default to
/etc. I was then able to view the smb settings.

I found changing the settings would crash the program and
corrupt the smb.conf file.

Comment 1 marcin 1999-12-03 10:42:59 UTC
hi,
had the same problem too this week, on two different computers. when trying to
configure samba, there was a segmentation fault. couldn4t start linuxconf
anymore. when i checked the rpm with gnomerpm, it complained about bad file
atrributes on the conf.linuxconf file. yesterday i uninstalled, and installed
it again from the cdrom. looks different now (no tree menu), maybe a different
version...
when i check the rpm now, it is alright, but when i start linuxconf, then exit
it, and check again: same problem with file attributes in conf.linuxconf and
/var/log/htmlaccess.log.
really weird.

Comment 2 Dale Lovelace 1999-12-03 19:45:59 UTC
Using linuxconf-1.16r10 configuring samba I could not reproduce this. This
will be released as an errata when testing is finished. I would suggest
upgrading when this is available.

Comment 3 dbelliz 1999-12-04 09:52:59 UTC
Dale,
This is how I got it to crash on a freshly installed system. Although linuxconf
would not always exit with a segmentation fault the end results would be the
same, linuxconf unexpectedly exiting and trashing the /etc/smb.conf.

When in linuxconf try to disable either the printer or netlogn shares and the
program will bomb and /etc/smb.conf will be 0 bytes.

Do I need to enter a new bug if I find some thing new with linuxconf? I got the
DHCP to DNS update going but I had to change ewhere linuxconf looked for the
dhcpd.leases. Linuxconf wanted dhcpd.leases to be in /etc and dhcpd put it in
/var/state/dhcpd/dhcpd.leases. Once I went into linuxconf and changed it worked.

marcin,
I ran into the none tree mode of linuxconf but I forgot how I fixed it.

Comment 4 Dale Lovelace 1999-12-06 20:54:59 UTC
I disabled printers and the netlogon share with the errata version of
Linuxconf with no repurcussions. I am expecting this errata to go out Real Soon
Now [TM]. Please upgrade when released. Feel free to append to this bug if you
have any problems with the errata release.

------- Email From  David Bellizzi <dbelliz@angmar.com> 12/09/99 12:36 -------
Attached to Bug # 6565.

Comment 5 Michael K. Johnson 1999-12-09 21:55:59 UTC
When you find new bugs, please enter them as new bugs rather than
appending your comment to an existing bug report.  Things get
confused otherwise...  We need to be able to close out bugs that
have been fixed and get an accurate report on which bugs are fixed
and which ones are not.

Comment 6 Michael K. Johnson 1999-12-15 21:00:59 UTC
1.16r10-2 released

Comment 7 hostmaster 2000-03-02 12:46:59 UTC
Hi,

I am using RH6.1 with linuxconf 1.16r10-2. When trying to install the samba-rpm
2.05a-12 linuxconf crashes with a segmentation fault.

A manual installation and configuration of the samba-2.06.tar.gz works fine.

bye