Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6531

Summary: linking with python, can't find libthreads
Product: [Retired] Red Hat Linux Reporter: corrin.lakeland
Component: pythonAssignee: Nalin Dahyabhai <nalin>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-01-13 21:50:42 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description corrin.lakeland 1999-10-30 09:44:59 UTC
The python RPM that comes with 6.1 (Python 1.5.2) has been
compiled with threads enabled but the threads library
(libpthread, linuxthreads) isn't found by the runtime system
(does it still exist?).

This means python cannot be linked into any C program, even
one that doesn't use threads.

I tried compiling python from source and come up with the
same problem until I configured with --without-thread

Comment 1 Michael K. Johnson 1999-11-19 20:26:59 UTC
Try compiling your application with -lpthread

Comment 2 Nalin Dahyabhai 2000-01-13 21:50:59 UTC
I'm assuming that Michael's suggestion has solved your problem, and am therefore
closing this bug.  If this is not the correct solution, please reopen this bug.