Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 653

Summary: Packaging emacs
Product: [Retired] Red Hat Linux Reporter: pavel.janik
Component: emacsAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2CC: pavel.janik
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1998-12-30 20:10:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description pavel.janik 1998-12-30 09:41:24 UTC
Hi,

Emacs source package have some bugs:

- signal patch is (really?) not needed according to DaveM
for Emacs >20.2

- doesn't contain leim-package so it is useless for
non-english languages

- french description of main package is missing (I'm not
frenchthouhg ;-)

- why --with-pop is not in nox package?

- make install wants install-info which is not in our PATH
(so add /sbin to PATH before make install)

- some non-existent files are tried to strip (put ls -l
before for cycle of stripping)

- patches can be cleaned up so no find . -name *orig is
needed (see
ftp://ftp.inet.cz/pub/People/Pavel.Janik/Emacs-Patches). My
patche are updated for 20.3

- binary file emacs and emacs-20.3 are the same - symlink
can be sufficient, I think

- HOSTTYPE variable is not used in build section

- build of nox and X11 can be grouped together (configure
has almost the same parameters which can be in some variable
- e.g. COMMON_FLAGS etc.)

- what is the reason for XPUREDEF and PUREDEF variables???

Sorry for bothering with this, but I need czech language
support which really is in emacs-20.3 that comes from
ftp.gnu.org (well, with leim installed) but redhat's is
useless now.

Comment 1 Jeff Johnson 1998-12-30 20:10:59 UTC
Fixed in dist-6.0/emacs-20.3-5. (Look for emacs-leim package).