Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6507

Summary: fatal crash when trying to delete nonexisting modem
Product: [Retired] Red Hat Linux Reporter: frese01
Component: rp3Assignee: Michael K. Johnson <johnsonm>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-11-06 03:51:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description frese01 1999-10-29 16:59:47 UTC
rp3 reported a fatal crash (core dump) when I
tried to delete the only registered modem on ttyS0.
(When running rp3 for the first time, the modem
which is really on ttyS1 was misdetected on ttyS0,
probably because it was in use at the time.).
The only way I was able to get rid of the ttyS0
modem entry was to delet /etc/wvdial.conf

Comment 1 Michael K. Johnson 1999-10-29 18:07:59 UTC
As far as "misdection" goes, you are correct that it cannot
detect a modem that is currently in use.  There's not much of
a way around that, unfortunately.  It just didn't look at that
device that was in use and took the next best.  If there really
was not a modem on that device, it should have told you that it
couldn't automatically detect a modem, and was offering you its
best guess...

The fatal crash, I think, is fixed in our current development
sources.  We're trying to track down a different bug before
doing a new release.

Comment 2 Michael K. Johnson 1999-11-01 22:49:59 UTC
We are releasing rp3-1.0.1-1 as an errata update to Red Hat
Linux 6.1.  Please see if it fixes this bug for you.  We expect
it to do so, but it's always possible that we fixed a different
bug from the one you are experiencing.

Comment 3 Michael K. Johnson 1999-11-06 03:51:59 UTC
We'll assume that rp3-1.0.1 fixes this problem.  Please reopen
this bug report if you find otherwise.  Thanks!