Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6428

Summary: rpmlib.h: include files wrong?
Product: [Retired] Red Hat Linux Reporter: stewart
Component: rpmAssignee: Jeff Johnson <jbj>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-10-27 16:39:37 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description stewart 1999-10-27 16:19:29 UTC
I may be wrong here, but...

file /usr/include/rpm/rpmlib.h includes the following header
files:

	/* This is the *only* module users of rpmlib should need to
include */

	/* and it shouldn't need these :-( */

	#include <rpmio.h>
	#include <dbindex.h>
	#include <header.h>
	#include <popt.h>

Should the above files (excluding popt.h) not have a prefix
of rpm/ as the header files are in the /usr/include/rpm
direcotry?

I know what the comment says, but something still seem to
need them.  And there is that whole completeness thing. :)
I noticed this when building ucd-snmp (from RH 6.0) with
rpm-3.0.3-6x.src.rpm

Comment 1 Jeff Johnson 1999-10-27 16:39:59 UTC
Add -I/usr/include/rpm to CFLAGS.

I can't change to
	#include <rpm/header.h>
because that prevents rpm itself from building.

The include used to be
	#include "header.h"
but that prevented some (perl?) automated (and broken!) binding
generator from working.