Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6401

Summary: Login hangs after installation of RedHat 6.1
Product: [Retired] Red Hat Linux Reporter: greg.tarsa
Component: kernelAssignee: Michael K. Johnson <johnsonm>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: ezolt, greg.tarsa
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-08-08 14:03:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description greg.tarsa 1999-10-26 22:19:51 UTC
Machine: Toshiba Portege 7010CT

When booting up for the first time after a successful
installation the keyboard is completely locked up.  No
regular keys, not ctrl-alt-del, nothing.

Workaround: disable GPM.

Comment 1 Jay Turner 1999-11-30 19:22:59 UTC
Yes, we have seen this on a couple of different laptop models.  Thanks for the
feedback.

Comment 2 ezolt 1999-11-30 19:51:59 UTC
Hi Guys,
	I think that I know what might be the cause of this.  Attached is the note that
I sent to Alan Cox.  He has since temporarily reverted the patch because it was
causing characters to be dropped on the serial port.

Try to resolve it with him.  This will probably solve quite a few problems.

--Phil

---------------------------------------------------------------------
Hi All,
        After two solid days of frustration, a coworker and I found
and fixed a bug in the the Linux ps2 mouse/keyboard driver.  After a
certain amount of mouse use, the keyboard and mouse would hang,
leaving the machine unresponsive to keypresses.

The problem was as follows.

The Linux driver polled the ps2 status register faster than the device
could keep up. The FreeBSD ps2 driver inserted a pause between the
polls.  By doing the same in Linux, the problem disappears.

This bug showed up on our Digital HiNote CT475 laptops.  Without the
fix, the boxes are quite useless.

This fix shouldn't harm anyone, but may help some.  (It may eliminate the
"pc_keyboard jammed" warning that appears right below the patch.)

Attached is a patch for both 2.2.13 and 2.3.28.

Cheers,
--Phil

diff -ur linux-orig/drivers/char/pc_keyb.c linux/drivers/char/pc_keyb.c
--- linux-orig/drivers/char/pc_keyb.c   Mon Aug  9 15:04:39 1999
+++ linux/drivers/char/pc_keyb.c        Mon Nov 15 19:27:09 1999
@@ -433,7 +433,7 @@
                                handle_scancode(scancode, !(scancode & 0x80));
                        mark_bh(KEYBOARD_BH);
                }
-
+               mdelay(1);
                status = kbd_read_status();

                if(!work--)

Comment 3 Alan Cox 2000-08-08 14:03:01 UTC
Yep - this one is probably a 2.4 thing. The delay cannot be simply inserted ,
instead the entire
PS/AUX handler needs to be reconstructed so that it runs with IRQ's enabled and
uses timers
to do its interrupting. Non trivial- not for 2.2

I feel bad about this one as its our bug and your suffering...
How about submitting a variant where you can do psaux=slow on the init line -
I'd take that


Comment 4 Michael K. Johnson 2002-01-18 01:00:36 UTC
I'm assuming that this is fixed in the 2.4 kernels and we're not going to
go back and fix it for 2.2 kernels.  If I'm wrong about 2.4 kernels, let
me know.