Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6289

Summary: Latest "RHEA" boot images severely broken
Product: [Retired] Red Hat Linux Reporter: uche.ogbuji
Component: installerAssignee: Jay Turner <jturner>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-11-30 20:45:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description uche.ogbuji 1999-10-23 21:03:20 UTC
First of all, note that I am a registered owner of a
shrink-wrap copy, product ID number aa8217b18a6ca871, but
not only is your product broken, but your Web site is as
well, so I can't request installation support on-line.
Luckily, I'm not a newbie.

I downloaded

updates-RHEA-1999:045.img
boot-RHEA-1999:044.img
pcmcia-RHEA-1999:044.img

And then proceeded to install on my Dell Inspiron 7000
Laptop.  The first problem is that if I use either the
"pcmcia" or "boot" images, and enter "text updates" as the
advisory states, the boot process hangs at a line saying

/sbin/loader

It only boots into the installer works if I use "text
updates expert" or "text updates text".

Then, using the pcmcia boot image, since I'd like to set up
my network card during install, it goes through, reads the
updates, lets me select packages, but then immediately
throws a Python trace-back when it tries installing the
first package "Electric Fence".  I believe the traceback was
in todo.py or somesuch.

So I try the regular boot image, and that finally works.

Once installed, it's OK, but from an installation
standpoint, RH 6.1 was and continues to be an inexcusable
mess.

Comment 1 Jay Turner 1999-10-25 17:12:59 UTC
We have seen a couple of situations where there is a race condition on
the loading of the updates disk.  It is triggered by having the cdrom
in the drive while loading the updates image.  The workaround is to
boot the machine (using the pcmcia.img in this case) and then tell the
installer that you would like to install from the cdrom, at which time
the installer will prompt you to insert the cdrom.  This will prevent
the hang that you are seeing at /sbin/loader.

As for the traceback that you are seeing, I would need to see details
of that in order to diagnose your problem.

Comment 2 Yaron Minsky 1999-11-29 00:18:59 UTC
I second this bug.  I suggest you post the workaround to this race condition to
the page that has the update to anaconda.  There are a number of bugs that are
duplicates of this, by the way, including:

6708, 587, 6723, 7089, etc.