Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6262

Summary: ping will eternally ping a down system, even if "-cNUM" is set
Product: [Retired] Red Hat Linux Reporter: shane
Component: netkit-baseAssignee: Jeff Johnson <jbj>
Status: CLOSED DUPLICATE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.0CC: scott.delinger
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-01-27 20:05:59 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description shane 1999-10-22 19:25:33 UTC
A small flaw in the way that ping behaves.

If a user tries to do a "ping -c3 somehost", the ping
will run eternally, until the host is brought up on the
network and 3 packets comes back.

I believe this represents a flaw in design, as admins
often use "ping" in scripts to test if a sytems is up
or down, then execute some function if it's down.

If ping never returns, then the script will hang.

Most other Unix systems do NOT do this.  They send
N number of packets, wait W length of time, then
exit.

This represents a HUGE problem for shell scripters, as
they then have to grope around the process table to
find their 'ping' PID, then manually kill the process
after some period of time.  A real pain in the behind.

So...in the meantime, I'll use an HPUX system instead
of a RedHat linux system as this represents a very
large problem for me.

v/r
Shane


------- Additional Comments From   11/07/99 18:09 -------
Even though netkit-base*-36.rpm supposedly fixed it, it is broken in
37 again, so this probably also breaks in RH6.1, which uses 37.

Comment 1 Scott Delinger 1999-11-07 23:11:59 UTC
supposedly netkit-base*36.rpm fixed this, but 37 broke it again. Since
RH6.1 also uses 37, I think this problem exists there as well. This
needs fixed immediately (I thought my Big Brother install was broken,
but it turns out it was RedHat's ping). ping isn't rocket-science!

Comment 2 Jeff Johnson 2000-01-27 20:05:59 UTC
*** This bug has been marked as a duplicate of 8724 ***