Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6255

Summary: Shipping incorrect or out-of-date docs is unprofessional
Product: [Retired] Red Hat Linux Reporter: tchrist
Component: man-pagesAssignee: Trond Eivind Glomsrxd <teg>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: gafton, tchrist
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-05-30 16:59:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description tchrist 1999-10-22 17:18:34 UTC
Something that reads:

   This documentation is no longer being maintained and may
be inaccurate
   or incomplete.  The Texinfo documentation is now the
authoritative
   source.

just *has* to be fixed!  Here's a list of such evil pages:

    basename.1 cat.1 chroot.1 cksum.1 comm.1 csplit.1 cut.1
date.1
    dirname.1 echo.1 env.1 expand.1 expr.1 false.1 fmt.1
fold.1 groups.1
    head.1 id.1 join.1 logname.1 md5sum.1 nice.1 nl.1
nohup.1 od.1
    paste.1 pathchk.1 pr.1 printenv.1 printf.1 pwd.1 sleep.1
sort.1
    split.1 stty.1 su.1 sum.1 tac.1 tail.1 tee.1 test.1 tr.1
true.1
    tty.1 uname.1 unexpand.1 uniq.1 users.1 wc.1 who.1
whoami.1 yes.1

It's completely unprofessional to ship a manpage that says
it's wrong
and that you don't even intend to fix it!  Ok, I realize
that it's
not your software.  It's the FSF's, and they really don't
care about
the POSIX.2 requirement.  But the buck stops with you,
because you're
the system integrator.  You have to find a way of shipping
correct and
up-to-date versions of those manpages.  Possibly even the
FSF would
accept back your fixes.

Comment 1 Cristian Gafton 2000-02-05 03:35:59 UTC
unfortunately, no, FSF is not interested in supporting man pages anymore. They
want to dump them for the benefit of the info pages, whcih they argue that it is
much better and easy to use.

The hacks for the man pages tell you at least where to look for the information
rather than leaving you in the dark...

Comment 2 Cristian Gafton 2000-05-22 15:02:59 UTC
assigned to teg

Comment 3 Trond Eivind Glomsrxd 2000-05-30 16:59:59 UTC
This is not a bug, this is FSF. I really dislike it, but there's not much we can
do about it.

Comment 4 tchrist 2000-06-06 14:02:18 UTC
Apparently you and I disagree about the responsibility of a vendor
to ship integrated, documented, and tested products.  You simply 
grab whatever you feel like, stuff it into your "product", and ship
it.  It is completely unimproved.  In a feat worthy of Pontius       
Pilate, you then attempt to wash your hands of all responsibility
here, pretending that there's nothing you can or should do about
such an embarrassing situation.  Shame on you!  You are the vendor.
The buck stops at YOUR doorstep.  This is a fine demonstration of 
why Redhat doesn't merit serious consideration as a system vendor. 
You aren't.  If it's crap to start with, you leave it as crap.  No 
vendor would dare shove such an attitude down the customers' and
investors' throats, but apparently in this Brave New World of Open 
Sores Software, you think it's normal that there be no care or
concern toward QUALITY.  You can be sure that I will cite this case
as a demonstration to journalists.
 
WTFM.