Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6247

Summary: Upgrade using updated images fails with NTFS partition present
Product: [Retired] Red Hat Linux Reporter: mnelson
Component: installerAssignee: Jay Turner <jturner>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 6.1CC: srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-10-22 16:28:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description mnelson 1999-10-22 16:07:04 UTC
I am one of the unfortunate souls who has been bitten by the
NTFS bug in
the Red Hat 6.1 installer that bites when upgrading.  This
morning, I
created new "boot" and "updates" floppies from the new image
updates,
and tried once again to upgrade my system.  I used
boot-RHEA-1999:044.img and updates-RHEA-1999:044.img.
Failure.

Here is the sequence of events:

Boot from boot-RHEA-1999:044 boot disk, select English, US
kbd, insert
CD when requested, then inserted updates-RHEA-1999:044
floppy when
requested.

After the "Welcome!" screen, I selected "Upgrade Existing
Installation".

I got a window with "Error Mounting ext2 filesystem on hda1:
Invalid
Argument"

After hitting OK, I got an "Exception Occured" window with
the following
python traceback:


Traceback (inntermost last):

File "/usr/bin/anaconda", line 225, in ?

  intf.run(todo, test = test)

File "/tmp/updates/text.py", line 1009, in run

  rc = apply(step[1](), step[2])

File "/tmp/updates/text.py", line 222, in __call__

  parts = todo.upgradeFindRoot()

File "/tmp/updates/todo.py", line 1149, in upgradeFindRoot

  isys.umount('/mnt/sysimage')

File "/usr/lib/python1.5/site-packages/isys.py", line 8, in
umount

  return _isys.umount(what)

SystemError: (22, 'Invalid Argument')


My two disks are partitioned thustly:

hda:
   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1       497   3992121    7
HPFS/NTFS     (Win NT4)
/dev/hda2           498       523    208845    6
FAT16

hdb:
   Device Boot    Start       End    Blocks   Id  System
/dev/hdb1             1         2     16033+  83
Linux         (/boot)
/dev/hdb2             3        35    265072+  82  Linux swap
/dev/hdb3            36       243   1670760   83
Linux         (scratch)
/dev/hdb4           244      1229   7920045   83
Linux         (Red Hat 6.0)

The 'scratch' partition (hdb3) is used for trying out
various Linux
distributions as they hit the streets, and may or may not
contain a
valid Linux installation of some sort or another.

I tried going to VC2 and mounting my / partition.  it worked
fine.


You have mail in /var/spool/mail/mnelson

Comment 1 Jay Turner 1999-10-22 16:28:59 UTC
*** This bug has been marked as a duplicate of 6215 ***