Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6201

Summary: megaraid can see the first disk only on DELL 2300 smp
Product: [Retired] Red Hat Linux Reporter: dwatson
Component: kernelAssignee: Michael K. Johnson <johnsonm>
Status: CLOSED RAWHIDE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.1CC: jlee, neil_hurst
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-06 06:18:54 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description dwatson 1999-10-21 21:56:56 UTC
kernel 2.2.12-20smp
DELL 2300
Adaptec 7890 imbedded ( Not Used )
Adaptec 7860 imbedded ( CDROM )
DELL PERC / SC with 3 18 GB LVD Hot Pluggable
Was OK on RedHAt 6.0
Recomplied kernel with old megaraid drivers ( V1.01 )
     - no change

Comment 1 jlee 1999-10-27 00:16:59 UTC
I too have the same problem.  We have a Megaraid series 428 and 438
on separate servers.  After installing Redhat 6.1 I could only see
the first logical drive.  Recompiling did not help.

Comment 2 jlee 1999-10-28 17:16:59 UTC
Try compiling the latest kernel 2.2.13.  That seemed to fix the
problem for me.

Comment 3 Richard Keech 1999-11-30 06:12:59 UTC
I too see this problem.  Host is Dell 4300 with Dell Power Edge Raid
Controller (PERC) II, which is OEM of AMI Megaraid.
Only the first logical disk could be seen, despite all logical disks
showing in the bios messages at boot time.
If booting to Red Hat 5.2 rescue disks, then all logical disks
can be seen.

Comment 4 Cristian Gafton 2000-01-04 22:26:59 UTC
Assigned to dledford

Comment 5 Bill Nottingham 2000-02-06 06:18:59 UTC
*** Bug 8034 has been marked as a duplicate of this bug. ***This should be fixed in the Raw Hide kernel.

Comment 6 Matt Domsch 2000-07-10 14:52:26 UTC
Logic added to linux/drivers/scsi/scsi.c to probe all LUNs on MegaRAID 
controllers.