Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 61395

Summary: replace words with Moby?
Product: [Retired] Red Hat Linux Reporter: Adrian Likins <alikins>
Component: wordsAssignee: Eido Inoue <havill>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.2CC: aleksey, herrold, mattdm
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: 3-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-11-08 17:32:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Adrian Likins 2002-03-19 00:53:22 UTC
the public domain word list at:


http://www.dcs.shef.ac.uk/research/ilash/Moby/

It's "official" word list seems to be about twice
as big as the current words file. 

Perhaps worth investigating?

Comment 1 Trond Eivind Glomsrxd 2002-03-19 21:30:04 UTC
Hardly anything uses the package anyway... it's not used as a spelling
dictionary, for one. Any reason why we need to keep it?

Comment 2 Adrian Likins 2002-03-19 22:07:50 UTC
suspect there are a fair amount of 3rd party/perl scripts/etc that
use it. I seem to recall some griping when it moved to  /usr/share/

I use it occasionally with `look foobar` or just grepping it to
find proper spelling, but I have no idea how common that useage is.

does lsb require it?

Comment 3 Trond Eivind Glomsrxd 2002-08-09 22:56:33 UTC
We'll stay with the current one for now.

Comment 4 Matthew Miller 2002-11-07 20:35:18 UTC
Could we get this changed from "wontfix" to "later" or something? The current
word list *really* does suck -- it's full of arbitrary omissions. See bug #77071
for some random examples. I'll not reopen this myself, but I hope you will
consider doing so.

The SCOWL project -- already used by aspell -- seems like it'd provide a good
alternative. (It'd be kind of nice for the word list to actually line up with
the words being used by the spellchecker....)  http://wordlist.sourceforge.net/

Comment 5 Elliot Lee 2004-08-04 15:06:02 UTC
Not much of a reason not to update to a better list!

Comment 6 Elliot Lee 2004-08-04 15:06:53 UTC
*** Bug 77071 has been marked as a duplicate of this bug. ***

Comment 7 R P Herrold 2005-03-30 15:22:12 UTC
Strangely, the bugzilla was not updated to reflect this change being applied:

words-3.0-5
-----------
* Tue Mar 29 2005 Karel Zak <kzak@redhat.com> 3-2
- replace word list with much better Moby Project words list (#61395)
- revise %description; ispell/aspell no longer uses words