Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6118

Summary: RedHat 6.1 installer fails w/SCSI boot drive and IDE data drives
Product: [Retired] Red Hat Linux Reporter: jered
Component: installerAssignee: Jay Turner <jturner>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-10-20 15:06:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description jered 1999-10-20 04:35:29 UTC
I found that the RedHat 6.1 installer fails in a multitude
of ways when I try to install on a machine with both IDE and
SCSI hard drives, where the SCSI drive is the boot drive.

First, Disk Druid.  In the graphical installer, even when
/dev/sda is given as the only disk I want to allow / on, it
still gets put onto /dev/hda. this is wrong.

Second, when installing LILO, the installer only gives me
the options of installing on the MBR of /dev/hda, or on the
first partition of another drive. There is no way for me to
install to the MBR of /dev/sda from the GUI installer. This
is wrong.

LILO also loses whn Linux knows about hard drives that the
BIOS was told to ignore (because it wants the BIOS ID
number), but LILO is a festering pile of dog droppings and I
don't really expect you to fix that. I do suggest possibly
replacing LILO with GRUB, a friendlier (and more
maintainable) boot loader, however.

I've submitted this with severity normal as most people with
this sort of setup know enough about linux to bash the
installer into submission.

--Jered
jered@mit.edu

Comment 1 Jay Turner 1999-10-20 15:06:59 UTC
The best way around these issues is to perform an expert install,
using fdisk to partition the drive, which will allow you to put the
root partition and /boot partition anywhere that you wish.  Once this
is done, lilo will allow you to install to the MBR os sda.