Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6099

Summary: 'spell' problems: stdin only, duplicate misspellings
Product: [Retired] Red Hat Linux Reporter: Chris Siebenmann <cks-rhbugzilla>
Component: ispellAssignee: Michael K. Johnson <johnsonm>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-11-19 22:23:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Chris Siebenmann 1999-10-19 21:16:50 UTC
A traditional spell command will spellcheck one or more
files given on the command line (or stdin if there are no
files given on the command line), and misspelled words will
only be given once.

 The 'spell' script included in the ispell RPM will only
spellcheck standard input and will repeat misspelled words
as many times as they occur in the input.

Reproduction:
$ echo This spel command is awful at catchng spel mistakes
>/tmp/spelltest
$ spell </dev/null /tmp/spelltest
[no output]
$ spell </tmp/spelltest
spel
catchng
spel

 The simple fix appears to be to replace spell with the
following shell script:
	#!/bin/sh
	cat "$@" | ispell -l | sort -u

(This bug report is applicable to RedHat 6.1 unless the
behavior of 'ispell -l' has changed, which the manpage
claims it has not.)

 There is also no manpage for the spell command.

Comment 1 Michael K. Johnson 1999-11-19 22:23:59 UTC
Makes sense; I've changed the spell script for ispell-3.1.20-23, which
will be in the next RawHide.  Thanks!

Comment 2 Michael K. Johnson 1999-12-10 21:12:59 UTC
*** Bug 7734 has been marked as a duplicate of this bug. ***