Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6086

Summary: problems with ppp
Product: [Retired] Red Hat Linux Reporter: colgor
Component: initscriptsAssignee: Michael K. Johnson <johnsonm>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: avibrazil, wmusic
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-12-06 19:16:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description colgor 1999-10-19 15:26:44 UTC
I am running RedHat 6.1 with pppd 2.3.10. The problem is
that pppd does not connect to my ISP at all. It comes back
with a termination on signal 15. I have an internal Compaq
Netelligent 56kbps modem. Even when I try to use kppp it
dies after saying "Starting pppd..."
Do I need something in the /etc/options or options.ttyS?
files? My modem connects to the ISP, but pppd is not working

Comment 1 Avi Alkalay 1999-11-05 22:21:59 UTC
I got this in /var/log/messages:

Nov  5 20:03:44 mozart ifup-ppp: pppd started for ppp0 on /dev/ttyS1
at 115200
Nov  5 20:03:44 mozart modprobe: can't locate module char-major-108
Nov  5 20:03:44 mozart pppd[15293]: The remote system (ppp0) is
required to authenticate itself but I
Nov  5 20:03:44 mozart pppd[15293]: couldn't find any suitable secret
(password) for it to use to do so.
Nov  5 20:07:58 mozart modprobe: can't locate module char-major-108
Nov  5 20:07:58 mozart pppd[15335]: The remote system is required to
authenticate itself but I
Nov  5 20:07:58 mozart pppd[15335]: couldn't find any secret
(password) which would let it use an IP address.


------- Additional Comments From   11/05/99 19:28 -------
I actually have "noauth", "novj" in the /et/ppp/options file but I
can still not connect. By tailing /var/log/messages, I can see PPP is
started on my ISP server, but it never starts on my workstation. Is
someone working on this problem?
I am using RP3, the latest version, and am getting very frustrated.

Comment 2 Michael K. Johnson 1999-11-08 15:36:59 UTC
This is a new pppd "feature" where it will not replace the default
route if one exist on the machine.  It instead gives this relatively
cryptic error message.

Is this PPP connection intended to be your default route to the
internet?

------- Additional Comments From   11/08/99 11:53 -------
The connection is my default connection to the INTERNET. What's this
new 'feature'. Do I need the 'noipdefault' option in my options file?

Comment 3 colgor 1999-11-10 16:21:59 UTC
I have been following the Bug Track on ppp for RedHat 6.1 and am
having the following problems:
I have a ethernet card in my computer, but I disabled the "eth0
interface" using  the netconfig tool. I even went and commented out
the "alias eth0 " line from /etc/conf.modules.
Now, when I dial my ISP using the modem and RP3, I actually connect,
but PPP is never started on my machine. It just hangs there and I get
the following

	Serial connection established
	Using interface ppp0
	Connect ppp0 <--> /dev/ttyS2
	LCP: timeout sending Config-Requests
	Connection terminated

Please could you help me with this? I am very frustrated trying to
get on to the internet, and RedHat 6.1 is unusable at this time
without my internet connection. I have all the latest updates,
including ppp-2.3.10-3.rpm, the latest initscripts, and the latest
rp3 package.

I also have PPPOPTIONS=noauth in /etc/sysconfig/network-scripts/ifcfg-
ppp0.
Thank you.

Comment 4 Michael K. Johnson 1999-11-19 15:28:59 UTC
This problem will be fixed for good in our next release of initscripts.
I'm not sure how you are getting a default route set if you do not have
an ethernet device, but that's what is happening.

Colgor: your problem is unrelated.  Please open a seperate bug report
so that we can track it separately.

Comment 5 Michael K. Johnson 1999-12-06 19:16:59 UTC
Oops, forgot to close this bug report.  The current initscripts errata
release (made some time ago) should fix this entirely.

Comment 6 Wallace Music 2000-01-16 01:09:59 UTC
I'm having a similar problem connecting to an ISP with Linux version 6.1. The
modem makes a connection, the carrier is detected, starts PPP immediately. Then
PPP daemon has died: (exit code = 10. Disconnecting. Just starting to learn
Linux, I am completely lost and am trying everything.